Page 1 of 2

Gentoox Loader v6.01

Posted: Thu Jan 12, 2006 4:01 pm
by cheesyboofs
thought I would condense my two Xboxes in to one now that your new loader supports web booting.
So I flashed my 1.3 with Gentoox Loader v6.01 and put both my HDD’s in, and it doesn’t see either disk? It boots from the web fine and I can see both disks under the HDD menu but I can not see either on the main menu to boot from.
So I moved both HDD’s back in to my 1.6 with loader 5.11 on it and that boots fine with both disks in!!!
So I have now booted the 1.3 off the web re-flashed it with 5.11 and that too now works with both disks in, it boot and works fine.


New loader 6.01

Posted: Tue Jan 17, 2006 5:05 am
by murraykj

I was just wondering, as your using the BIOS as a loader, do you have a DVD playback kit, i found that on version 5 and the new version 6 of the XBE would not continue with a normal boot process with the dvd kit dongle attached. Just wondering if it does the same thing with the Bios version of the loader as well.

Its not a big deal (-: anyways, nice in one way because if someome else uses the system they cant accidentally boot the linux up and probally improperly reset it and corrupt the filesystem. so it kinda works like a key to prevent the linux from loading if necessary.

The NetBoot option is really Nice, Shallax did a Great Job on it.

Best Wishes

Kenny Murray

Posted: Wed Jan 18, 2006 6:58 pm
by cheesyboofs
Right my findings so far. Now I have moved both hard drives into my 1.3 and have it booting fine from 5.11 and I am reluctant to touch for a bit. This now free’s up my 1.6 for development, so I stuffed a 13Gb HDD in it and copied bios v6.01 (from the web site) to bank 1 and your v6.01 from your mail (Cromwell.bin) to bank 2.

I then booted from bank 1 no disk seen at the boot menu so then booted from bank 2, no disk seen. This was to be expected as I have not put a bootable OS on the disk yet. I then booted the Xbox from the web (cool!) using Cromwell.bin (v6.01) and proceeded to set up the disk.

All went well except when I came to format the disk and mount it; it did not recognise /dev/hda2 I had to use /dev/ide/host0/bus0/target0/lun0/part2 instead.

After install I rebooted and all was well, at POST it saw the disk and booted from it. So I switched back to bank one (original v6.01 from your web site) and that worked too?

So in summary;

1. Either the first copy of the v6.01 bios I copied to the TSOP of my 1.3 was corrupt in some way and I’m lucky I didn’t kill my Xbox,
2. v6.01 doesn’t let you use disks formatted up under v5.11, I may rule this out later in the week by moving my live server disks from my 1.3 to my 1.6 if I can bear any more down time.
3. Or the v6.01 BIOS doesn’t work on v1.3 Xboxes! (I doubt it though)


Posted: Wed Jan 18, 2006 7:17 pm
by cheesyboofs

Right so I have my working v1.3 Xbox with Bios v5.11 and a long established Native install on two 200Gb HDD's.


I have my working v1.6 Xbox with Bios v6.01 and a freshly formatted 13Gb Native install.


I move my two WORKING 200Gb HDD's into the v1.6 Xbox and it don't see um at the boot menu?


But it does at the HDD tools menu.


"Ahh but what if you put the v6.01 bios on the v1.3 Xbox" Done that does the same thing.

Does this mean that if I want to get my v1.3 NAS booting from the web and my HDD's I have to backup 400Gb of data and try a reformat of /dev/hda?


Posted: Thu Jan 19, 2006 4:57 am
by orochi
why rush away from 5.11? only netboot has changed, and those of us that run headless, you cant choose those options anyway ;D

nice tv btw

Posted: Thu Jan 19, 2006 12:59 pm
by cheesyboofs
Because my Xbox now has no DVD so to recover it I need to boot from the LAN / WAN, and I'm sure I can handle a little right click select with my eye's shut. :wink:

Posted: Tue Jan 24, 2006 8:50 pm
by cheesyboofs
Well I spent 15 hours backing up my 400Gb NAS and then re-formatted it and re-partitioned it and put the OS back on it, and F*CK me the disks still don’t boot off the v6.01 BIOS. :cry:
I have now put v5.11 on bank one and v6.01 on bank two, I will run it from bank one and if I need to recover / rebuild it I will switch to bank two just to set the disks up.

Posted: Wed Jan 25, 2006 10:50 pm
by ShALLaX
Sorry for the delay on looking into this. I'll do it now!

Posted: Tue Feb 07, 2006 1:04 pm
by LeeWiggy

My first post, so please excuse anything stupid I might say.

I followed cheesyboofs native Pro install on a Version 1.0 XBox (to act as a media server). No problems at all, good work to the both of you.

However like him (for your 6.01 and 6.02 loader), I can't see a native icon at the bottom of the boot screen. Works fine with 5.11.

Tried your latest 6.03c with the result that your new option icons were there, but no native again. Also the screen background did not fully draw, it filled in behind the header then gave up. The icons appeared on the black background.

I flash the loader to a Xecuter 2.6CE if that makes a difference.

It's just that this thread went quiet, so I don't know if there is a workaround that I missed.

Keep up the good work.

Posted: Tue Feb 07, 2006 1:19 pm
by cheesyboofs
YES!!!!!! I love you dude, I was starting to think I was going F*cking mental and that I was the only one seeing this.

This doesn't help you much I know but it has cheered me up! Have you had chance to try v6.04 yet? Although until shallax him self sees the problem I don’t suppose he can fix it!

Just out of curiosity, what size hard drive you using? Mine failed with two 200GB but seemed to work with a 13GB, may have some thing to do with it! May be a size cap with the new Bios’s

Posted: Tue Feb 07, 2006 4:33 pm
by BigBowser
Hi all,
I said the same thing to Shallax in a recent post:
Ohh also, check if you can that reiserfs works natively with the Loader, because I followed the tutorial made by cheesyboofs to run gentoox 100% natively and on boot no linuxboot.cfg was found, but I tried it with ext3 FS and after linuxboot was found... Did you remove reiserfs support on boot?
ext3 do works but reiserfs don't :? so don't worry cheesybofs you haven't got mental problems :D

Posted: Tue Feb 07, 2006 5:54 pm
by LeeWiggy

I err.... am very fond of you to.

The HDD is a 120GB and is locked (don't suppose that matters though).

I have not tried 6.04, with 6.02 and 6.03 (which was more scary with the half paint thing !) not allowing me to boot, I though I would Post to see if it was me first !!

I try not to flash to often as I normally have to do it over the network (pooh DVD player), and Firefox locked up the last time (got that stomach sinking feeling !). Must remember to use IE for that.

I only run one HDD, but with the crappy Thompson drive refusing to recognise more and more of the CD-R/W I throw at it, the ability to get ResctooX up and running by some other method is very appealing.

Still, now we know someone else has seen it as well we can't both be barking.....can we ?

Posted: Tue Feb 07, 2006 8:37 pm
by cheesyboofs
LeeWiggy wrote:But with the crappy Thompson drive refusing to recognise more and more of the CD-R/W I throw at it, the ability to get ResctooX up and running by some other method is very appealing.
BigBowser wrote:ext3 works for not reiserfs so don't worry cheesybofs you haven't got mental problems
Not so sure about this bit dude, I have a 13Gb reiserfs install working fine under v6.01, It seems to affect drives formatted under v5.11 and / or my 200 Giggers!

Posted: Sat Mar 11, 2006 12:43 am
by ShALLaX
Is your partition which contains /boot definitely marked as active/bootable (see in fstab)?

As it stands, this is the code for drawing the "Native" icons:

Code: Select all

void InitNativeIcons(void) {
   ICON *iconPtr=NULL;
   u8 ba[512];
   int driveId;

   for (driveId=0; driveId<2; driveId++) {
      if (tsaHarddiskInfo[driveId].m_fDriveExists && !tsaHarddiskInfo[driveId].m_fAtapi) {
         volatile u8 *pb;
         int n=0, nPos=0;

         BootIdeReadSector(driveId, ba, 0, 0, 512);

         //See if there is an MBR - no MBR means no native boot options.
         if( !(ba[0x1fe]==0x55) || !(ba[0x1ff]==0xaa)) return;

         (volatile u8 *)pb=&ba[0x1be];
         //Check the primary partitions
         for (n=0; n<4; n++,pb+=16) {
            if(pb[0]&0x80) {
               //Bootable flag IS set on this partition.
               CONFIGENTRY *entry = (CONFIGENTRY*)LoadConfigNative(driveId, n);
               if (entry!=NULL) {
                  //There is a valid config file here.
                  //Add an icon for this partition
                  iconPtr = (ICON *)malloc(sizeof(ICON));
                  iconPtr->iconSlot = ICON_SOURCE_SLOT1;
                  iconPtr->szCaption="  Native";
                  iconPtr->functionPtr = DrawBootMenu;
                  iconPtr->functionDataPtr = (void *)entry;
                  selectedIcon = iconPtr;
So we see:

1) It checks for a drive which exists and is not a CD drive.
2) it checks that there is an MBR.
3) It checks all the primary partitions (not extended ones).
4) It checks that the drive is bootable/ active
5) It checks that there is a linuxboot.cfg file
6) It adds the icon

If any one of the above steps fails, the next will not be called. Steps 1-5 are all preconditions to having a native icon. As you can see, the FS type is not an issue. A helpful hacker out there might try putting debugging printk's in each step to see just how far it gets before failing.

Also, yes, this function IS being called:

Code: Select all

void IconMenuInit(void) {
   int i=0;
   ICON *iconPtr=NULL;
   for (i=0; i<2; ++i) {
      //Add the cdrom icon - if you have two cdroms, you'll get two icons!
      if (tsaHarddiskInfo[i].m_fAtapi) {
         char *driveName=malloc(sizeof(char)*14);
         iconPtr = (ICON *)malloc(sizeof(ICON));
         iconPtr->iconSlot = ICON_SOURCE_SLOT2;
         iconPtr->szCaption = driveName;
         iconPtr->functionPtr = BootFromCD;
         iconPtr->functionDataPtr = malloc(sizeof(int));
         *(int*)iconPtr->functionDataPtr = i;

   // For the Pro/ Home Gentoox distributions.  If MCE isnt installed
   // Gentoox Pro/ Home will be selected as the default icon.

   // Largely for MCE.  MCE will get selected as the default boot icon
   // if it is installed.

   // For booting a Packlet from the internet.
#ifdef LWIP

   iconPtr = (ICON *)malloc(sizeof(ICON));
   iconPtr->iconSlot = ICON_SOURCE_SLOT0;
   iconPtr->szCaption = "Advanced";
   iconPtr->functionPtr = AdvancedMenu;
   iconPtr->functionDataPtr = (void *)TextMenuInit();

   //Etherboot icon - if it's compiled in, it's always available.
   iconPtr = (ICON *)malloc(sizeof(ICON));
   iconPtr->iconSlot = ICON_SOURCE_SLOT3;
   iconPtr->szCaption = "Etherboot";
   iconPtr->functionPtr = BootFromEtherboot;

   //Set this to point to the icon you want to be selected by default.
   //Otherwise, leave it alone, and the first icon will be selected.
   //selectedIcon = iconPtr;

Posted: Sat Mar 11, 2006 1:19 pm
by cheesyboofs
yes chap, if you read the full post you will see that just by changing the bios down to 5.11 makes it boot, ergo the problem must be within the 6.-> bioses. However it doesn't seem to afect all native v6 installs.
Thank for the above post though as its good for us mear mortals to see how it all works :wink: