Page 1 of 1

GentooX Loader 5.1 not working

Posted: Fri Jan 07, 2005 2:44 pm
by kopibean
Hi, I have updated the Gentoox Loader to v5.1 by running Magic. But now my Gentoox can't boot up properly. I boot up my Gentoox from EvoX dashboard and there are several errors during boot up, like some file system cannot be mount error, cannot load eth, etc.

And finally, it show a text screen saying that "I cannot start your X Server. It is likely that your server ....." and prompt a "Yes" and "No" text button, which I am unable to 'click' using my xpad.

How can I restore my Xbox Gentoox now? I have gotten a lot of my file inside and reformatting my xbox is a no go now. Thanks in advance for all the help render.

Posted: Fri Jan 07, 2005 2:54 pm
by vplayer

I dont think you need to rollback.. All you need to do is tackle one error at a time, starting from the first.

Tell us what the first error is and hopefully you will get a clue on what file to fix.

Posted: Fri Jan 07, 2005 3:10 pm
by kopibean
I have tried several stuff, even restoring to the v4.5, and finally found the cause of the problem. :)

When Gentoox loader booting up, there are now 3 choices - Stardust, Fatx, Native. I think the default is to start as native which isnt my case. My F drive is native but my E drive isnt (it is still FATX). So when it boot up from native, it couldn't load the E drive and thus causes all the device to fail subsequently.

So now I choose using my XPAD to start it with FATX and it is working now. Thanks for the help rendered :)

Posted: Fri Jan 07, 2005 3:19 pm
by kopibean
One problem now. How can I set the default to boot from FATX->GENTOOX?

The current boot sequence is a bit cumbersome as i have always need to use the xpad to scroll and select FATX and then GENTOOX before gentoox will load. Thanks

Posted: Fri Jan 07, 2005 11:59 pm
by vplayer

I think you can do that by changing Linuxboot.cfg on your E drive that starts Gentoox. But I will wait for someone who has tried it to answer.


Posted: Sat Jan 08, 2005 11:36 am
by kopibean
I have take a look at the linuxboot.cfg in E Drive but they dont seem to have much config that can be set. Is there any expert that can advise on setting the default boot setting? Thanks.

Posted: Sat Jan 08, 2005 11:56 am
by ShALLaX
If you have a native kernel... then thats residual from a previous installation of xebian... or something NON-GENTOOX. The loader defaults to native installations over non-native. What you need to do is run fdisk and then either delete your native partitions or disable your active partititon.

This is NOT a loader bug, its pebkac.

Posted: Sat Jan 08, 2005 12:39 pm
by kopibean
Hi, I have installed xebian long time ago but have since installed MCE and GentooX twice which formatted the F partition to native filesystem. Hence it should be unlikely that I am still having residual of xebian installation, right?

By the way, I am not sure the default is it really boot up in native. If at the Cromwell boot screen and I just waited until it time out, it will start the default boot sequence but half way through the sequence, it will display error such as "mount error on fatx", "error on eth" etc and finally display the error in a text screen saying "I cannot start your X Server..."

However, if I use the Xpad to select the FATX and then GENTOOX in the Cromwell boot screen, everything went well and Gentoox boot up just like in the past.

Can anyone help to explain what's went wrong?

Posted: Sat Jan 08, 2005 2:10 pm
by ShALLaX
If you see a Native icon, that is the initially selected icon. MCE installs natively so it is probably trying to boot that.

Posted: Sat Jan 08, 2005 2:29 pm
by kopibean
Oh, that's may be the problem. So is there anyway that i can rectify that?

I have installed MCE previously but has since reinstalled Gentoox Home (Native option) to replace it. In this scenario, what can I do to remove the MCE completely? Thanks.

Posted: Sat Jan 08, 2005 4:11 pm
by kopibean
I have found that there is a /boot directory in my XBox and the linuxboot.cfg in this directory is different from that of the E Drive. This is probably the left over bit from MCE.

Can I simply delete this directory to remove the native boot option from the loader? or is there other way that I can do that? Thanks.

Posted: Sat Jan 08, 2005 9:54 pm
by stevie

I had the same problem, that the loader 5.1 was starting native instead of FATX.
I installed Pro with install option Native, but you still need to boot FATX.
And yes, I had Xebian installed before.

So I did like ShALLaX explained:

Code: Select all

xbox root # fdisk /dev/hda
with command p I got this list

Code: Select all

Command (m for help): p

Disk /dev/hda: 60.0 GB, 60000000000 bytes
16 heads, 63 sectors/track, 116257 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1           15510       16006      250000+  82  Linux swap
/dev/hda2  *        16006      116258    50527213+  83  Linux
then with command a I changed partition 2 to non-bootable

Now my Pro is starting like before.

For Linuxboot.cfg syntax have a look at:


Posted: Sat Jan 08, 2005 9:57 pm
by ShALLaX
That is exactly correct :)

Job well done to you guys, you have pointed out a little issue which will be fixed in the later versions which I'm about to release. As a quick fix, you can do either as Stevie has shown, or you can rm -rf /boot/*

Posted: Sun Jan 09, 2005 8:58 am
by kopibean
Thanks Shallax and Stevie, I have done a fdisk to deactivate the active partition and now it is working just the past :) Thanks.