Portage problems running magic

Post information here about bugs - please remember to provide an accurate and detailed description and, if possible, steps on how to replicate the issue.
Post Reply
wahoo434
Newbie
Posts: 1
Joined: Sat Mar 12, 2011 12:00 am

Portage problems running magic

Post by wahoo434 » Sat Mar 12, 2011 12:07 am

When running magic for the first time on a fresh Pro 5.1 install:

Code: Select all

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/10.0

To upgrade do the following steps:
# Check 'eselect profile list'.
# Find the number that corresponds with the default/linux/x86/10.0 profile.
# Use 'eselect profile set <number>' to set a new /etc/make.profile symlink.
#
# Reference: http://www.gentoo.org/doc/en/gentoo-upgrading.xml
# See: "General instructions" in Section 3. "Profile updating instructions"

A new version of portage is available, this will be installed now.
emerge portage...


!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/x86/10.0

[ebuild  NS   ] dev-lang/python-2.6.6-r2 [2.5.2-r7] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst" 
[ebuild     U ] sys-apps/portage-2.1.9.25 [2.1.6.4] USE="(ipc%*) -python3%" 
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.6.6-r2)
[blocks B     ] app-admin/eselect-news ("app-admin/eselect-news" is blocking app-admin/eselect-1.2.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 !! Emerge failed.

 !! Note the error(s) above then press enter to continue.
After "eselect profile set 1", the warnings about having a deprecated profile go away but the same blockage remains:

Code: Select all

[ebuild  NS   ] dev-lang/python-2.6.6-r2 [2.5.2-r7] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst" 
[ebuild     U ] sys-apps/portage-2.1.9.25 [2.1.6.4] USE="(ipc%*) -python3%" 
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.6.6-r2)
[blocks B     ] app-admin/eselect-news ("app-admin/eselect-news" is blocking app-admin/eselect-1.2.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 !! Emerge failed.

 !! Note the error(s) above then press enter to continue.
Any ideas on how to work around this? Thanks for any help in advance.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests