unable to install glib 2.8.1

Talk about anything related to Gentoox or Gentoo.
Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
BCIcdrz
Newbie
Posts: 4
Joined: Tue Aug 30, 2005 9:01 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

unable to install glib 2.8.1

Post by BCIcdrz » Wed Aug 31, 2005 12:20 pm

im trying to update my glib, but after /configure and make and make install

or emerge glib

gtk or even emerge -V glib will sees 2.6 somthin, new gtk needs 2.7.1 or higher... spent 6 hours trying to fig how.. really hard for me (3 day old linux newb)

I was able to get my printer to work (HP psc 1210v) but i want to get its scanner to work.

any ideas why i cant get it to update?

BCIcdrz
Newbie
Posts: 4
Joined: Tue Aug 30, 2005 9:01 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by BCIcdrz » Thu Sep 01, 2005 7:10 am

yawn, gussig this forum section not read alot

User avatar
clpalmer
Power user
Posts: 288
Joined: Sat Jan 29, 2005 6:38 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by clpalmer » Thu Sep 01, 2005 2:45 pm

I'm kinda confused as to which version of glib you're trying to install and which one you have. Are you downloading a version and compiling it or are you using emerge? Emerge doesn't necessarily have the newest versions of things. It takes time to make packages out of the releases. If you want the latest release of something, you'll often have to download it and compile yourself.

If you do that, I don't believe emerge will show you the latest version you just installed cuz it doesn't know you installed it manually. However, if you use emerge and get the version of gtk and glib it has, they should work fine together. Why do you need a newer version of either?

And what does the glib and gtk problems have to do with your printer and scanner drivers? Please elaborate a little more on your problems. The clearer you are, the more likely you are to get a response.

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by orochi » Mon Sep 05, 2005 6:56 am

eep!

im trying to update my glib, but after /configure and make and make install
use emerge glib


if there is an error, output here what it says


is there a masked package for it?

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 7 guests