Successful magic upgrade to kernel 2.6

Talk about anything related to Gentoox or Gentoo.
justincx3
Linux User
Posts: 13
Joined: Mon Jan 31, 2005 1:00 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by justincx3 » Sun Apr 17, 2005 10:07 pm

i have succesfully upgraded the kernel,
but then when I boot back to 2.4, make some file changes, then go back to 2.6 the files appear to be corrupt!
i dont know why I would go back to v2.4.

I presume gentoox wont break now.. resulting in an unbootable system. i am currently updating my system right now (15/89) after making some changes to make.conf file.

i will format the F drive with reiser4 and will try to transfer all GentooX pro 1.5 files from the E drive to the F drive after all updates are done. wish me luck.

User avatar
shadycady
Linux User
Posts: 15
Joined: Thu Mar 03, 2005 1:56 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Where is Home 4.0?

Post by shadycady » Tue Apr 19, 2005 5:57 pm

shadycady wrote:well despite the fatx driver problem everything works .. so I want to fudge with it plus I am anxious to see this new version

I love GentooX

Why whats your problem GAWD !!!

Don't be jealous because I have been chatting with babes online All Day

OK Shallax I have been chatting with babes online All Day so... but I grow tired of these women they bore me...

now i am just wondering when we should be seeing the new release??
Xenium Ice (OS 2.3.0); 320Gb WesternDigital HD; Evox M8+ bios; Linux dual-boot GentooX; Lastest CVS build XBMC with built-in XLink Kai: Evolution VII (Global Network Gaming); XBOX to USB adapter . . .

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by orochi » Tue Apr 19, 2005 11:09 pm

when it wont take hours to do a cd install with fatx :)

linbox
Linux User
Posts: 17
Joined: Tue Nov 04, 2003 2:18 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

upgraded with magic on native install no format required

Post by linbox » Thu Apr 21, 2005 2:11 am

I ran magic on my xbox
I do have gentoox installed native on hda1 everything went OK and I did not have to backup E and format. It booted right up and I could see E with the command ls -lah /mnt/fatx/e. I was actually quiet surprised. I was expecting to format e. I did not know how yet, but was ready to figure it out through the internet.

Any ideas why did not have to format.

I don't use the original hard drive. I have a 80GB drive which I prepared with the harddrive format utility from xbins.

braden.compton
Newbie
Posts: 7
Joined: Sat Apr 23, 2005 5:36 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Success, albeit with some wierdness

Post by braden.compton » Sat Apr 23, 2005 6:47 am

A week ago I (successfully) finished rebuilding my gentoox box (formerly running Pro-1.4), and am now running a 2.6 kernel.

Here's what I did:
  • Installed a new 160Gb HDD (after duplicating old C, D and E "partitions").
  • Used XBpartitioner to initialise new F "partition".
  • Installed Pro-1.5 on a native reiserfs partition in G-drive territory.
  • Set hdparm appropriately.
  • Emerged ccache, sudo, bind-tools, ntp, nfs-utils, screen, lynx and prelink.
  • Emerged xorg-x11 (6.8.2-r2) and manually configured to use nvxbox driver with DRI.
  • Emerged evilwm (0.99.17) and corefonts.
  • Emerged mythfrontend (0.17), mythvideo, mythdvd, mythmusic, mythgallery, mythnews, mythbrowser and xine (to replace mplayer for mythdvd).
  • Minor configuration to get things working.
  • Tested system for a week. Worked perfectly (as before under native Pro-1.4).
  • Used magic to upgrade kernel to 2.6 (didn't let it touch xorg etc.)
  • Tested for a week; some issues (see below).
Problems I am experiencing:
  • While mythvideo seems to work fine (using either mplayer or xine playing divx and 3ivx encoded files), and mythdvd seems to work fine (using xine; mplayer outputs garbled audio) livetv and anything recorded on the backend stutters every few seconds (audio and video). This problem did not exist while running the old 2.4 kernel.
  • Getting this message dumped to the kernel log: "xbox kernel: i2c-xbox.o: SMBus collision!"
What I have done and am currently doing about it:
  • Tried turning off all filters and CPU intensive effects etc. in mythtv. No effect.
  • Tried moving to nptl. No effect.
  • Tried re-emerging a newer version of mplayer. No effect.
  • Am currently doing an "emerge --newuse world" which will, among other things, upgrade all the mythtv components to 0.18. Will report on my progress.
What I might consider doing if all this fails:
  • Compile my own kernel. I will *DEFINATELY* use modules (monolithic kernels make debugging and upgrading a nightmare. SHALLAX - why did you do it man?). Will probably try some more aggressive scheduler and I/O patches. I suspect that my answer lies in kernel configuration, but I don't really want to go there, because that would actually require time on my behalf. Time I don't really have.
  • Debug that SMBus error. Truthfully, I'd rather someone else track this one down. I'm far too lazy for that. But if I absolutely HAVE to...
Thoughts? I'd love to hear if anyone else has had issues with mythtv and a 2.6 kernel with gentoox (or better still, if they have NO issues and can help me resolve mine). All my other linux boxen run significantly better with 2.6. Note again: everything worked perfectly before magic-ing up to a 2.6 kernel.

Hope to hear from you guys soon!

Regards,
Braden.

braden.compton
Newbie
Posts: 7
Joined: Sat Apr 23, 2005 5:36 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Looks like the 2.6 forcedeth driver might be the problem...

Post by braden.compton » Tue Apr 26, 2005 3:01 am

Hi guys,

Well, I finished the "emerge --newuse world", with no success. I really should have THOUGHT the issue through before firing off the blunderbuss, but hey, it happens. It would seem the problem is network performance (all my mythtv recordings are accessed over an NFS share):
  • Did a "time dd if=/dev/zero of=/.test_file bs=1024 count=1000" and was shocked to find it took over 2mins! Less than 800Kb/s.
  • Ifconfig reveals an ENORMOUS number of transmit errors. Bummer.
  • Tried using SCP. Couldn't get more than 750Kb/s that way either.
  • Emerged in ethtool and netperf. Netperf reckons I get 88.8Mb/s to the server. Strange.
  • Had a look on the gentoo forums, and found a report of a similar problem. Seems that the forcedeth driver in kernel 2.6.11 has issues. Some people have reported success with building the driver directly into the kernel. Shallax has already done this, so no solution there.
Preliminary conclusion: the 2.6 kernel we are getting through magic has some horrible network problems. Either that, or I've overlooked something very simple (which is possible). Can someone else do some testing and confirm this bug?

Sadly, I've already spent more time that I can afford to on this. Might get around to building a few test kernels with different forcedeth driver patches later in the week. Don't hold your breath though... if you need it fixed straight away, do it yourself... and emai me a copy while you're at it ;-)

Regards,
Braden.

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by orochi » Tue Apr 26, 2005 5:54 am

only network problems I have had, which are really ndiswrapper problems, is via ssh, iwconfig reports 11mb/sec for my wireless connection to my accesspoint, where as if i am typing on the keyboard plugged into my xbox, it shows 2mb/s benchmarks back that up too, no biggie, i just went back to using wired

braden.compton
Newbie
Posts: 7
Joined: Sat Apr 23, 2005 5:36 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by braden.compton » Tue Apr 26, 2005 12:19 pm

Orochi - are you implying that you get normal (read 8-10MB/s) throughput on your 2.6 kernel xbox through the wired LAN adapter? Can you confirm this using a real-world benchmark (file copy or something... not netperf or similar)? That would tell me I'm barking up the wrong tree.

Braden.

braden.compton
Newbie
Posts: 7
Joined: Sat Apr 23, 2005 5:36 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

No go with 2.6.11.7

Post by braden.compton » Wed Apr 27, 2005 11:49 am

Couldn't help myself. Compiled 2.6.11.7, but still no go. 750Kb/s throughput. Not good enough :(

User avatar
clpalmer
Power user
Posts: 288
Joined: Sat Jan 29, 2005 6:38 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by clpalmer » Wed Apr 27, 2005 2:44 pm

I still have crap network speeds with mine, and I run 2.4 kernel still. I used to get 800-ish KB/s and then during the course of screwing with my DNS/DHCP settings on my PC that I test against, I started getting closer to 3MB/s or so. Once I was able to get 10-11MB/s using windows command line ftp client on the PC. However, I haven't seen that since and my usual is around 3-4MB/s. Still crap for a 100Mb network.

braden.compton
Newbie
Posts: 7
Joined: Sat Apr 23, 2005 5:36 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Giving up... going back to nvnet

Post by braden.compton » Thu Apr 28, 2005 7:30 am

Well, I can't get this thing going. Switched back to the nvnet driver. Working fine.

If anyone DOES manage to get usable throughput with forcedeth, drop me a line!

Braden.

kopibean
Adept
Posts: 66
Joined: Sat Nov 27, 2004 12:42 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Magic for Home 3.2

Post by kopibean » Sun May 08, 2005 6:42 am

Hi,

I read about all the thread about the workaround for Home 3.2 to run magic. But I am kind of loss when you mentioned backup E, format E, and restore back E drive. Could someone kind to show me the exact command to do that? For example,

root> magic
root> <what is the command to backup E>
root> <what is the command to format E>??

I would really like to upgrade my Home 3.2 kernel, so any help is most appreciated. Thanks.

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by orochi » Sun May 08, 2005 7:20 pm

braden.compton wrote:Orochi - are you implying that you get normal (read 8-10MB/s) throughput on your 2.6 kernel xbox through the wired LAN adapter? Can you confirm this using a real-world benchmark (file copy or something... not netperf or similar)? That would tell me I'm barking up the wrong tree.

Braden.
using lan is fine, ndiswrapper allows you to use native NDIS drivers for windows on linux, its a ndiswrapper problem other than kernel issue, lan transfer is fine for me on wired, wireless is another story

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: Magic for Home 3.2

Post by orochi » Sun May 08, 2005 7:21 pm

kopibean wrote:Hi,

I read about all the thread about the workaround for Home 3.2 to run magic. But I am kind of loss when you mentioned backup E, format E, and restore back E drive. Could someone kind to show me the exact command to do that? For example,

root> magic
root> <what is the command to backup E>
root> <what is the command to format E>??

I would really like to upgrade my Home 3.2 kernel, so any help is most appreciated. Thanks.
run magic
use a dash to backup your e:
use a dash to format your e:
copy files back to e:
boot gentoox

orochi
Gentoox Guru!
Posts: 606
Joined: Sun Oct 24, 2004 8:11 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Post by orochi » Sun May 08, 2005 7:26 pm

perhaps speed problems are caused by the amount of memory xbox has, anyone here have 128mb memory and still have low speed xfers?

Locked
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Who is online

Users browsing this forum: No registered users and 4 guests