Page 3 of 4

Posted: Mon Oct 11, 2004 5:21 am
by Casper1786
when following your guide, do I need 2 install GentooX the normal way first? like native 2 E install? If So How much free space do I need on my E Drive for this install, is like 1.69Gb enough? as thats whats free right now on it

and does any of this Relate to MCE, cause I wanna put that on the G Drive without Losing all my F Drive data. MCE is priority, but I figured since I'm installing MCE, I might as well install GentooX on the same Partition

also I'm a Linux n00b so please bare with me as I have NO idea what i'm doing, but I have nothing 2 lose either

also you guys keep refering 2 sectors, now I have an X3 in my system an Partition Table info says my G drive starts at Block 268435455 and ends at Block 320173055, is this the sectors you guys talk about?

also right now I don't have a USB mouse, but I do have a USB keyboard, is this ok?

Posted: Wed Oct 20, 2004 6:19 pm
by ShALLaX
I dont get what all these scripts are.. all you need to do is change /etc/gentooxinstaller: START=XXXXX to START=268435457... and then run sh /etc/gentooxinstaller... that should just _work_. No need to mess with fstabs or anything else. All you need to do is select "native" from the list of installation types. If "Native" doesnt show up, then youll need to make a hack to make it show up.

Posted: Fri Oct 22, 2004 11:23 am
by Casper1786
woah, gotta try that, I actually just gave up on this crap, but I'm gonna try this now and if it works, well awesome. great info Shallax

Edit: nm Removed Dummie Question, tho I still had problems on install, I'll figure it out later, but for now i go 2 bed as i have work in the morning

Posted: Fri Nov 19, 2004 10:11 pm
by Chinny
Casper1786 wrote:and does any of this Relate to MCE, cause I wanna put that on the G Drive without Losing all my F Drive data. MCE is priority, but I figured since I'm installing MCE, I might as well install GentooX on the same Partition
I'm sure that it'll work with MCE if you can edit the install script.

Posted: Thu Jan 27, 2005 12:29 am
by v_lestat
what id be more interested in doing and maybe shallax can flat out tell me no, is,,,, instead of making linux mount the rootfs file and then try to pull stuff from there why not just take it and tell it to install all the folders seperately or install it in 4 or 5 folders/files. it pulling from 1 file is killing the speed. the way hard drive access is whether its windows or linux its just killing it to mount 1 image and have to pull data from all that.

or do a pseudo native install with everything layed out on your F or G drive.
by pseudo native i mean just tell it to layout all the folders/directories right into the partition. i mean if you tell it to look at the size of the partition then have it write to itsself that its installing itself on the F or G partition, and it then lays out all the folders on that drive. while still alowing you to install stuff like games or apps or whatever on that partition .

i guess i dont understand why everything has to be crunched up into 1 image that must be "mounted".

i guess i look at houw gentoox runs vs how a linux install would run on he same hardware or pc and wonder why everything is shoved into one image ? lay it all out, uncompressed and folders and files available for linux to use.

or at the very least give us the option to do that without sacrificing our entire hard drive to a native install.

Posted: Thu Jan 27, 2005 8:18 am
by nobspangle
v_lestat, I don't think you understand this at all. Just like Windows must be installed on a Windows filesystem, Linux must be installed on a Linux filesystem. The main reason for this is that it must support posix file permissions and symbolic links.

For this reason it is not possible to install linux on to the fatx filesystem used on the F drive.

If you install linux on a PC you format the drive using a linux filesystem. This is one way of installing on the xbox, the other is to use a loopback, you can think of the loopback like a partition on your harddrive.

Each mounted loopback requires around 4-6MB of RAM, RAM is a precious resource on the xbox so several loopbacks would be bad. Also even if there was plenty of RAM installing into several loopbacks would make the system slower.
v_lestat wrote:i guess i dont understand why everything has to be crunched up into 1 image that must be "mounted".
All filesystems must be mounted. On unix systems you know about it because you do it yourself. On windows systems it happens for you without your control, but it is still happening.
v_lestat wrote:or at the very least give us the option to do that without sacrificing our entire hard drive to a native install.
You do have the option to do this, the project is open source, nothing is hidden away you simply have to learn how to do this, then you can do it yourself.

Posted: Fri Jan 28, 2005 12:20 am
by ShALLaX
the rootfs is not compressed at all.

There is already the option of installing without sacrificing your whole hdd - select Native. This takes up from F: and beyond leaving the original Xbox partitions untouched.

You cant just put the linux files straight onto a fatx partition because fatx doesnt have unix extensions (permissions, ownership etc...)

Posted: Tue Mar 08, 2005 8:24 pm
by Disabled
I did the G drive install the way shallax wrote.
I edited the start and format line in gentooxinstall.
Now I have the problem booting this thing.
I can mount /dev/hda2 where gentoox seems to have been installed to.
But launching gentooxx.xbe does not show a native install option.
So I edited the linuxboot.cfg to boot from /dev/hda2:
title native
kernel vmlinuz
initrd initrd
append root=/dev/hda2 pci=biosirq kbd-reset video=xbox:800x600,nohwcursor,hoc=10,voc=10
This worked perfectly - one time, so I completed the firstrun script. After rebooting my added lines to the linuxboot.cfg were gone, native was not found again either (the native option, not the fatx native I entered). So i reentered the section in linuxboot.cdg (besides initrd.gz got unpacked dunno why).
But the system did not boot up correctly. The last thing it says is:
init started ... stuff here ...
bad inittab entry: nittab
... cannot run /etc/init.d/rcS' : file not found

I'm a bit stuck here now.
What might be is that my initrd is false. Actually I don`t know what this file does, but it changed (got at least unpacked) by the firstrun script.
I just copied over (I assume) the old initrd file but that did not work either.
So now I`m stuck.

Hope someone can help booting this bitch up.

Thanks in advance.

P.s.: Thanks for all the effort youre putting into this ShALLaX!!

Posted: Tue Mar 08, 2005 8:31 pm
by ShALLaX
You werent meant to touch the linuxboot.cfg file at all.. you were meant to select the "FatX" icon... since the kernel is still stored on the fatx partition.

Posted: Tue Mar 08, 2005 8:42 pm
by Disabled
Well I'm pretty sure I tried that... unfortunately I`m just reinstalling, so I have to wait some hours now to test it again.

Posted: Wed Mar 09, 2005 12:20 am
by Disabled
Either I was stupid enough to not try the FatX stuff or something went wrong the first time.
All works like a charm now. Thanks Shallax for your answer!

A last thing: How can I find out the start and end sectors of my partitions to make absolutely sure I'm not using f drive space?

Posted: Wed Mar 09, 2005 4:21 pm
by cheesyboofs
I'm sorry but why are people still bothering with (G) drive support when the LBA28 boundary has long since been REMOVED? Just format up the last drive (F) as one big wopping data partition....

Posted: Wed Mar 09, 2005 4:39 pm
by Disabled
Were bothering because we want to keep the F drive in Fatx. I don't want to start Linux for the Daily DVD watching, Slide Show whatever, so I fire up XBMC instead loading my Pictures from the F drive.
I use Gentoox mainly for trying my Java/C++/LaTeX files I have to write for the university. And for my brother letting him try being a server admin :lol:

Posted: Wed Mar 16, 2005 10:44 pm
by fixedsys

I want to keep F: for my games and homebrew xbox appz.
I have a 250gb drive at the momemt and F: is using the rest of the drive.

I am guessing I need to off load all my thing from all the drives and start over. My mod chip gives me the option to create a G: drive. I was thinking of giving 20gb to 30gb to the G: drive upon its creation.
One that is done I would not mind doning a fresh install. I guess I am wishing there was a G: Drive Native option for the install. :)

I think I will try to reread this thread a few more times because I am not fully getting how to do this.

Reading through it seems as it you can have an existing F: drive that has space availage and you can cut off the last 20to30gb and make it a G: drive. It that what is being done? That would be nice so I did not have to waste hours transfering files. And if that is the way its being done do I have to be concerned with file fragmentation on F: ?

Say My F: was maxed with games and appz and I wanted to delete 30gig of stuff. Now I have free space but how could I cut off the last 30 gig of the drive with out disturbing data?


Posted: Thu Mar 17, 2005 1:33 am
by Trevante
I'm pretty sure you can't do that. If you have all F and want a G drive, you'll have to reformat both F and G for both drives to work. Not to mention that if you only delete 30GB of data, you're past the 137GB data boundary for F, and formatting a G drive would most likely cause data corruption. I tried formatting a G drive on an All-F 250GB even before I reached 137GB and it didn't work.

Your best bet would be to backup all the data on your F drive, switch to a bios that lets you do F and G, and then format both drives, and dump the data back on. If you have another Xbox with enough space (when I formatted my G drive, I backed up all my data onto my friend's Xbox (he too had a 250GB HDD) using an Xbox to Xbox ftp program (Took a few hours, but it was worth the wait), formatted my F and G drives, and then transfered my data back onto my Xbox). From now on, I just format F and G from the begining, as I find it easier to install Linux when F is only 137GB.