frustrated with xbox remote control

Ask questions about Gentoox MCE here!
Post Reply
simpsora
Newbie
Posts: 2
Joined: Thu Mar 17, 2005 5:48 am

frustrated with xbox remote control

Post by simpsora » Thu Mar 17, 2005 5:54 am

Hi,

I'm trying to finalize my gentoox MCE / mythtv setup, and I'm almost done. Gentoox and mythtv are both working great, I just need to get the remote controller working.

I'm using mythtv 0.17 on gentoox mce 1.1 with the MS stock xbox remote and dongle. I followed one of the seemingly endless number of howto's out there, and got lirc 0.6.6 installed and running. irw shows that lirc is receiving the correct keypresses from the remote.

However, mythfrontend doesn't seem to be responding to the remote. I have a usb keyboard connected, and I can control the box with that, but the remote just doesn't seem to do anything.

I've tried removing the xpad kernel module; didn't seem to help.
The myth user has .lircrc in its home dir (see below for snip).

Any thoughts on what might be going wrong, or other troubleshooting
ideas I can try? I can't wait to sit back and use it, but it's a pain going up to the kb every time i want to pause or ff :)


Thanks for any help..






###
# lircrc for MythTV, mPlayer and Xine by ShALLaX
###

# Up
begin
prog = mythtv
button = UP
repeat = 4
config = Up
end

# Down
begin
prog = mythtv
button = DOWN
repeat = 4
config = Down
end

User avatar
ShALLaX
Site Admin
Posts: 1973
Joined: Sun Aug 10, 2003 9:25 pm
Location: England
Contact:

Post by ShALLaX » Thu Mar 17, 2005 11:15 am

Make sure you are booting with the dongle connected - you cant connect it after (though it sounds like you are already booting properly.

Maybe mythtv somehow doesnt have correct focus?
The original Xbox adaptation of Gentoo

simpsora
Newbie
Posts: 2
Joined: Thu Mar 17, 2005 5:48 am

Post by simpsora » Fri Mar 18, 2005 4:22 am

ShALLaX,

Thx for the reply :)

The dongle is indeed connected at boot time. In fact, the remote is able to control the boot selection screen of GentooX loader.

I'm not sure about the focus -- since mythfrontend is the only X app running, I'd assume it has the focus, esp. since the keyboard controls it ok.

Here's the process I followed to get things working.. perhaps there's a mistake somewhere:
- emerge lirc-0.7.0 (did this before realizing I needed 0.6.6)
- unmerge 0.7.0
- follow your build directions here: http://forums.shallax.com/viewtopic.php ... light=lirc
- emerge --inject lirc-0.7.0-r1 (mythtv has a dependency on lirc >0.7)
- emerge mythtv 0.17 (it built using the +lirc use flag)
- add lircd to boot scripts
- add lirc_xir to autoloaded modules


Also, in reading about lirc and mythtv, it seems you can also use a binary called irxevent that passes ir events to x apps. I looked into this, but for some reason, I can't start x apps -- even when switching to a different VT and setting DISPLAY to localhost:0. I'm therefore unable to try using irxevent..

Any further thoughts?
Thanks for your help!

btw, gentoox rocks! I love seeing tux on m$ hardware 8)

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests