Page 1 of 1

1.6 Audio and other problems

Posted: Wed Jan 12, 2005 9:48 pm
by wHack
Ok here are a few porblems I'v been having and a couple of other questions

When running the rescue portion of the install I get to the Video Select tool and it says
Invalid Device Aborting
I know that the 1.6's Xcalibur chip has no overscan fix but it just says this then reruns itself over and over the only way past it I could find was to power off which may have left my install incomplete I'm not sure.

Then when I try to play a cd I get an error saying
MythMusic has encountered the following error:
Audio output: timed-out opening '/dev/dsp'.
I've gone through all the settings menus and tried to change the audio device but there is no other option

When trying to play a DVD I get no audio but I do get video and can access menus but it locks up after a short period of time or just goes black

When playing video still no audio surprise surprise also no subtitles on mkv files (don't know if it supports them or not but if not it would be nice)

Also can I mount fatx partitions and point to them for media using links?? For instance could I point to the Xbox CDRips on the E: drive by mounting E: to /mnt/fatx/e and then creating a link in the /Media/Music folder to the /mnt/fatx/e/TDATA/fffe0000/music folder thus allowing me to play the X-Box wma rips already on my X-Box??? If so how would I go about it. I've ssh'ed in as root and looked in the mnt folder and there are directories for fatx which I assume would be mountpoints but the fatx partitions are not mounted to them.

Please forgive me if any of this is painfully obvious just let me know but my linux knowledge isn't the best.

Posted: Wed Jan 12, 2005 10:24 pm
by wHack
In addition while ripping a DVD I got the error your connection to the Myth Transcoding Daemon has gone away. This is not a good thing.

Posted: Thu Jan 13, 2005 12:32 pm
by ShALLaX
Sorry, this isnt well documented at all.... MCE is not v1.6 compatible in the slightest.

MCE was made before 1.6's were (widely) available. When I get some time, I'll look into making it compatible.

Posted: Thu Jan 13, 2005 4:34 pm
by wHack
I see I've read where you had said that in the past but I was not aware to what degree. I assumed (rather foolishly I suppose) that it would still retain a greater degree of compatibility than it did. But I suppose the problems stetch far beyond just inability to set video modes. Well I was still having some other dificulties anyway. I had tried to install it after the f: partition using a custom sized F: partition. All seemed to go well till I realized it had reformatted my F: to fill the drive. Thus causing a filesystem conflict that would eventually have been a real mess. One of these days I need to go out and buy a used box to mod.

Posted: Thu Jan 13, 2005 4:39 pm
by wHack
Well is there anything I can do such as add a new sound driver to get better compatibility. I would really like to see what I might be able to do with it but I don't even know where the problems lie. If this is futile please feel free to let me know now.

Oh yeah and one last thing you might want to make note in the manual that 1.6's are rather drastically not supported at this time and that MCE will not work on them in any functional way so don't bother installing it unless you're intentions are to try and make it work and you have a good degree of skill